With SugarCRM's Winter 2018 release, there are critical changes to the platform that affects some REST API based integrations including Collabspot. Please click this link for a detailed information.


In response to these changes, all customers who are using SugarCRM 7.11.x are now required to install the Collabspot custom module in order for their Collabspot extension to work in Gmail.


If you're using SugarCRM 8.x, please go to this link instead.



Here are instructions on how to load the package into an instance:


1. Please download the attached zip file found at the bottom of this article. It contains the necessary pieces to be placed in the Sugar instance for Collabspot's integration to work fully.


2. Log in to Sugar.


3. Go to admin panel by clicking on the profile icon in the top right corner, then selecting "Administration" from the drop-down.



4. Click on the link "Module Loader" in the "Developer Tools" section.




5. Below the first table, click on the button "Choose file", and select the zip provided.


6. Click on the upload button to the right of the file name.




7. Once the package appears in the bottom table, click on the Install button next to its name.




8. Once it finishes installing (it just means files finished being copied around), go back to the admin panel.


9. In the section "System", click on the link "Repair".



 

10. Click on the first link "Quick Repair and Rebuild" and wait for it to finish (this may be a few minutes). 
If it shows an entry at the bottom of the results page about the db being out of synch, you can either just execute the SQL queries in it or leave it as is. The 
DB should not be affected by the package.